AWS issues have been resolved, and all systems are now fully operational. We continue to monitor performance closely.
Posted Oct 21, 2025 - 09:26 PDT
Update
AWS infrastructure issues appear to be resolved and systems are stabilizing.
Sales splits are still being processed, but we don’t yet have an official resolution time. We’ll continue to share updates as progress continues.
Thank you for your patience
Posted Oct 20, 2025 - 17:11 PDT
Monitoring
We are continuing to monitor AWS recovery efforts related to the ongoing US-East-1 outage. The issue is currently causing partial service degradation and intermittent errors across some components of our platform.
Customers may experience slower response times or brief periods of unavailability while AWS services stabilize.
Our engineering team is actively monitoring system health and will proceed with controlled service restarts once conditions in the affected region are fully stable. We will continue to provide updates as we receive more information from AWS.
Posted Oct 20, 2025 - 14:20 PDT
Update
Due to the ongoing AWS outage, our phone systems are now being affected. We are seeing issues with inbound and outbound calls. If you have a priority issue, please open a case with us via email.
Posted Oct 20, 2025 - 10:52 PDT
Update
We are experiencing ongoing AWS infrastructure issues that are impacting terminal operations and sales reporting.
*Important Advisory*: Please avoid making any configuration, pricing, menu, or other changes via the UI or API until further notice.
- Terminal Dates: We’re actively working to restore correct business dates across all terminals. - Sales Splits: Reprocessing is underway; updates will appear in reports once complete. - POS Functionality: Your POS will continue to operate in offline mode to ensure uninterrupted service. - Additional Impacts: You might experience a variety of other issues due to the widespread ecosystem impact.
We appreciate your patience and will provide further updates as progress continues.
Posted Oct 20, 2025 - 10:21 PDT
Identified
We are currently experiencing ongoing AWS infrastructure issues that are impacting terminal operations and sales reporting.
- Terminal Dates: We’re actively working to restore correct business dates across all terminals. - Sales Splits: Reprocessing is underway; updates will appear in reports once complete. - POS Functionality: Your POS will continue to operate in offline mode to ensure uninterrupted service. - Additional Impacts: You might experience a variety of other issues due to the widespread ecosystem impact.
We appreciate your patience and will provide further updates as progress continues.
Posted Oct 20, 2025 - 09:17 PDT
This incident affected: PAR POS on Admin7 and Customer Support Telephone Services.