TD Bank Declining Interac and Mastercard Credit Cards

Incident Report for Admin7 PAR POS

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 04:59 PDT

Investigating

We are currently seeing issues with Canadian Stores being able to accept Interac and Mastercard credit cards. Rebooting your payment device may help resolve the issue. We are working with TD Bank to resolve this issue as quickly as possible.
Posted Apr 26, 2026 - 17:13 PDT
This incident affected: PAR POS on Admin7.