In preparation for Monday’s menu updates, please hold off on making any non-critical updates or changes in Admin Portal from 7AM Eastern Time Thursday 1/22 through 5PM Eastern Time Friday 1/23. This includes pricing changes & updates, and non-critical item availability changes as PAR ensures that we have everything ready for Monday's menu launch.
Posted Jan 21, 2026 - 18:38 PST
Update
In preparation for Monday’s menu updates, please hold off on making any non-critical updates until after 5:00 PM ET on Friday, as PAR ensures that we have everything ready for Monday's menu launch.
Posted Jan 21, 2026 - 18:12 PST
Update
In preparation for Monday’s menu updates, please hold off on making any non-critical updates until after 5:00 PM ET on Friday, as PAR ensures that we have everything ready for Monday's menu launch
Posted Jan 21, 2026 - 16:13 PST
Monitoring
In preparation for Monday’s menu updates, please hold off on making any pricing changes until after 5:00 PM ET on Friday, as PAR ensures that we have everything ready for Monday's menu launch.