Payment Device Processing Issues

Incident Report for Admin7 PAR POS

Resolved

We have received multiple reports that payment processing is once again working.
Posted Mar 13, 2025 - 20:37 PDT

Investigating

We are currently investigating an issue with our payment partners regarding connectivity issues.
Posted Mar 13, 2025 - 19:31 PDT
This incident affected: PAR POS on Admin7.